Table of contents
Transformations
Download API definition:
GET https://qa-api.bentley.com/transformations/{transformationId}

This endpoint is used to track progress of a transformation for a provided transformationId.

Transformation status

Transformation status parameter provides information about the current status of a transformation. The status can have one of the following values:

  • Created - this status is assigned when the transformation is created, but background job has not started yet. Once the background job is started, initialization begins.

  • Initializing - a transformation in the Initializing status means that the background job has been started and is preparing to run the transformation. This process involves downloading all the necessary iModels and setting up other parameters as required by the transformation.

  • Started - when the transformation background job starts processing the iModel elements based on the transformation configuration, the status changes to Started. You can monitor the progress of the transformation during this stage by tracking the count of processed elements. This count allows you to estimate when the transformation might finish.

  • Succeeded - upon successful completion of the transformation, the status is set to Succeeded. This means all iModel elements have been processed as per the transformation configuration without any errors.

  • Failed - if an error occurs during the transformation process (while in the Initializing or Started statuses), the status changes to Failed. This indicates that the transformation has ended prematurely and would leave the target iModel in an invalid state if any intermediate changes were pushed. If the transformation is in an invalid state, it is necessary to use a new target iModel in order to proceed with further transformations.

  • Aborted - a transformation is labeled as Aborted when it is manually cancelled by the user. Note that a transformation cannot be cancelled if it has already finished (its status is either Failed or Succeeded).

Transformation error code

Transformation errorCode parameter provides information about error which occurred during transformation.

Description
Value
Name
API Errors.
[1 - 999]
Unknown API Error.
1
UnknownApiError
Transformation was terminated as it was stuck in created state for too long.
2
CreatedStateTimeOut
Transformation was terminated as it was running for too long.
3
JobRunTimeOut
Unknown errors which happened while executing transformation.
[1000 - 1999]
Transient network errors, set when there are transient issues with requests to other services. User should “try again later”.
[2000 - 2999]
Can not execute transformation, user action is required to fix the issue.
[4000 - 4999]
Transformation already started.
4001
TransformationAlreadyStarted
No changes to process.
4002
NoChangesToProcess
Maximum entities limit exceeded. Applicable for transformations started from 'Try it out' button located in developer.bentley.com site. Not applicable for transformations started with token generated by application registered at developer.bentley.com site.
4003
LimitedTransformationError
Cannot chain transformations.
4004
CanNotChainTransformations
Unsupported combination of transformation types.
4005
UnsupportedCombinationOfTransformationTypes
Invalid transformation parameters.
4006
InvalidTransformParameters
Invalid configuration.
4007
InvalidConfiguration
Change processing is not supported.
4008
ChangeProcessingIsNotSupported
Missing scope element.
4009
MissingScopeElement
Missing Repository Link.
4010
MissingRepositoryLink
Source repository link has no federation guid.
4011
SourceRepositoryLinkHasNoFederationGuid
Forking transformation was not executed, set for MergeFork transformation.
4012
ForkingTransformationNotExecuted
Fork relationship was not established between source and target iModels, set for MergeIModel transformation.
4013
ForkRelationshipIsNotEstablished
Could not populate federation guids, set for PopulateFederationGuid transformation.
4014
CouldNotPopulateFederationGuids
iModel contains elements without federation guids, set for MergeIModel transformation.
4015
ElementsWithoutFederationGuids
Could not create schema definition.
4016
CouldNotCreateSchemaDefinition
Missing spatial location model.
4017
MissingSpatialLocationModel
Schema errors.
[5000 - 5999]
Schema was not found.
5001
SchemaNotFound
Schema version was not found.
5002
SchemaVersionNotFound
Schema conflict.
5003
SchemaConflict
Data export errors.
[6000-6999]
Entity export error.
6001
ExportEntityError
Code spec export error.
6003
ExportCodeSpecError
Schema export error.
6004
ExportSchemaError
Element code conflict.
6005
ExportElementCodeConflict

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Authorization

You must have imodels_read assigned at the target project level and imodels_read assigned at the source project level within related configuration. If permissions at the project level are not configured, then you must have same assigned at the iModel level.

Alternatively, you must be an Organization Administrator for the Organization that owns a given project the iModel belongs to.

An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management see Bentley Communities Licensing, Cloud, and Web Services wiki page.

Rate limits

All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.

Request parameters

Name
Required?
Description
transformationId
Yes

ID of the transformation

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Response 200 OK

Returns transformation with the given ID.

json
{
    "transformation": {
        "id": "00000000-0000-0000-0000-000000000000",
        "status": "Created",
        "errorMessage": "",
        "processedElementCount": 0,
        "totalElementCount": 100,
        "createdDateTime": "2024-03-05T14:51:33.6133333Z",
        "startedDateTime": "2021-08-02T14:51:33.6133333Z",
        "finishedDateTime": "2021-08-02T14:51:33.6133333Z",
        "sourceChangeSetId": "0",
        "lastTargetChangesetPushed": "0",
        "_links": {
            "configuration": {
                "href": "https://api.bentley.com/transformations/configurations/00000000-0000-0000-0000-000000000000"
            }
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

Transformation with the given ID does not exist.

json
{
    "error": {
        "code": "TransformationNotFound",
        "message": "Requested Transformation is not available."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Transformation status

Name
Type
Description
Created
String
Started
String
Succeeded
String
Failed
String
Aborted
String
Initializing
String

Transformation

Name
Type
Description
transformation

Transformation

Transformation data.

Name
Type
Description
id
String

ID of the transformation.

status

Available values: Created, Initializing, Started, Succeeded, Failed, Aborted.

errorCode
Int32

Error code that gets filled if an error occurred during transformation.

errorMessage
String, null

Error message that gets filled if an error occurred during transformation.

processedElementCount
Int32

Number of elements that have been processed.

totalElementCount
Int32

Total amount of elements to process.

createdDateTime
Date-time

Time the transformation entity was created.

startedDateTime
Date-time, null

Time the transformation was initiated.

finishedDateTime
Date-time, null

Time the transformation was finished. Empty if transformation is still running.

sourceChangeSetId
String, null

ID of the last change set used for source iModel.

lastTargetChangesetPushed
String, null

ID of last changeset pushed to target iModel.

_links

Link to related configuration.

Links

Name
Type
Description
configuration

Link to configuration.

Link

Name
Type
Description
href
String

Link to a resource.

Error

Contains error information.

Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String, null

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

Name
Type
Description
error

Error information.