This endpoint is used to query a configuration entity with a provided configurationId.
Note: the type of configuration
in operation response is a union of different configuration types. Configuration type is denoted by transformType
property. API consumers should expect that new configuration types will added in the future. New configurations may have a different schema than the ones that currently exist so configuration
should be deserialized based on transformType
.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
You must have imodels_read
assigned at the target project level and imodels_read
assigned at the source project level within related configuration. If permissions at the project level are not configured, then you must have same assigned at the iModel level.
Alternatively, you must be an Organization Administrator for the Organization that owns a given project the iModel belongs to.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management see Bentley Communities Licensing, Cloud, and Web Services wiki page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request parameters
ID of the configuration
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Response 200 OK
Returns configuration for the given ID.
{ "configuration": { "id": "00000000-0000-0000-0000-000000000000", "transformName": "Transformation name", "comment": "comment", "createdDateTime": "2021-08-02T14:51:33.6133333Z", "modifiedDateTime": "2021-08-02T14:51:33.6133333Z", "transformType": "FilterByViewDefinition", "transformParameters": { "models": ["0x20000001201"], "categories": ["0x20000001201"], "neverDrawn": ["0x20000001201"], "alwaysDrawn": ["0x20000001201"], "isAlwaysDrawnExclusive": true, "subCategoryOvr": [{ "invisible": true, "subCategory": "0x20000001201" }], "clip": { "shapes": [{ "points": [ [0, 1, 2], [2, 3, 4], [3, 4, 5], [4, 5, 6] ], "trans": [ [5, 6, 7, 8], [6, 7, 8, 9], [7, 8, 9, 0] ], "zlow": 1, "zhigh": 2, "mask": true, "invisible": false }], "planes": [{ "invisible": true, "clips": [ [{ "normal": [0, 1, 2], "dist": 9, "invisible": false, "interior": true }] ] }] }, "perModelCategoryVisibility": [{ "modelId": "0x20000001202", "categoryId": "0x20000001203", "visible": true }] }, "_links": { "sourceIModel": { "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000" }, "targetIModel": { "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000" }, "sourceProject": { "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000" }, "targetProject": { "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 404 Not Found
Configuration with the given ID does not exist.
{ "error": { "code": "ConfigurationNotFound", "message": "Requested Configuration is not available." } }
Response 429 Too many requests
This response indicates that the user has sent too many requests in a given amount of time.
{ "error": { "code": "TooManyRequests", "message": "More requests were received than the subscription rate-limit allows." } }
Response headers
The number of requests exceeds the rate-limit for the client subscription.
View mode
Combine Physical Models configuration
Configuration data.
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Combine physical models configuration transform parameters.
Filter by view definition configuration properties
Configuration data.
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Filter by view definition configuration transform parameters.
Filter sub categories configuration properties
Configuration data.
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Filter sub categories configuration transform parameters.
Combine Physical Models configuration properties
Filter sub categories properties
TParams_FilterByViewDefinition_ClipData
Filter by view definition properties
Filter by view definition per model category visibility properties
Filter by view definition sub category override properties
TParams_FilterByViewDefinition_ClipData_ShapeData
TParams_FilterByViewDefinition_ClipData_PlaneData
Filter iModel configuration
Configuration data.
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Filter iModel configuration properties
Combine iModels configuration properties
Combine iModels configuration
Configuration data.
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
TParams_CombineIModels_IModel_Links
TParams_CombineIModels_IModel
Group and map configuration properties
Configuration data.
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Group and map created configuration transformation parameters
Array of EC schemas that will be added to target iModel after transformation.
Link to a mapping
Link to a group
Combine physical models v2 configuration
Indicates if unselected models must be grouped
Name of unselected models group. Must be specified if groupUnselectedModels is set to true.
optional parameter indicating if geometry simplification should be used (transforming parasolids to meshes). Default if not specified - false.
Group unselected models properties
Name for grouped models
Query for grouping models
Combine physical models v2 configuration properties
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Combine physical models v2 configuration transform parameters.
Create fork configuration properties
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Import iModel configuration properties
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Merge iModel configuration properties
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Populate Federation Guids configuration properties
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Merge fork configuration transform parameters links
Merge fork configuration transform parameters
Merge fork configuration properties
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Configuration
Single configuration
Links
Single iModel Configuration Links
Link
Link to a resource.
EC class definition
EC Schema name
EC Class name
EC schema definition
EC Schema name
EC Schema version
Returned group override properties
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.