This endpoint is used to query a list of configuration entities.
To get full configuration entities in a list set prefer header to return=representation
.
Note: when return=representation
is used, the type on entities returned in configurations
array is a union of different configuration types. Configuration type is denoted by transformType
property. API consumers should expect that new configuration types will added in the future. New configurations may have a different schema than the ones that currently exist so array items should be deserialized based on transformType
.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request parameters
Source or target project ID of the configurations.
The $top
query option requests the number of items in the queried collection to be included in the result. E.g. to return only first collection item provide the following query: $top=1
. When $top parameter is not provided default is set to 100. $top
value cannot exceed 1000.
The $skip
query option requests the number of items in the queried collection that are to be skipped and not included in the result. E.g. to return items from the collection starting at the third place provide the following query: $skip=2
.
Request headers
Indicates a level of details in the response. Valid values are return=representation
or return=minimal
. The default is return=minimal
.
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Response 200 OK
Returns configurations for the given project ID. If prefer header is not set, API will treat it as `return=minimal`.
{ "configurations": [{ "id": "00000000-0000-0000-0000-000000000000", "transformName": "Transformation Name" }], "_links": { "self": { "href": "https://api.bentley.com/transformations/configurations?projectId=00000000-0000-0000-0000-000000000000&skip=100&top=100" }, "prev": { "href": "https://api.bentley.com/transformations/configurations?projectId=00000000-0000-0000-0000-000000000000&skip=100&top=100" }, "next": { "href": "https://api.bentley.com/transformations/configurations?projectId=00000000-0000-0000-0000-000000000000&skip=200&top=100" } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 422 Unprocessable Entity
Invalid request to get all configurations.
{ "error": { "code": "InvalidTransformationsRequest", "message": "Cannot get Configurations.", "details": [{ "code": "MissingRequiredParameter", "message": "Required parameter is missing.", "target": "projectId" }, { "code": "InvalidParameter", "message": "'{number}' is not a valid '{$top/$skip}' value.", "target": "{$top/$skip}" } ] } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
View mode
Combine Physical Models configuration
Configuration data.
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Combine physical models configuration transform parameters.
Filter by view definition configuration properties
Configuration data.
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Filter by view definition configuration transform parameters.
Filter sub categories configuration properties
Configuration data.
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Filter sub categories configuration transform parameters.
Combine Physical Models configuration properties
Filter sub categories properties
TParams_FilterByViewDefinition_ClipData
Filter by view definition properties
Filter by view definition per model category visibility properties
Filter by view definition sub category override properties
TParams_FilterByViewDefinition_ClipData_ShapeData
TParams_FilterByViewDefinition_ClipData_PlaneData
Filter iModel configuration
Configuration data.
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Filter iModel configuration properties
Combine iModels configuration properties
Combine iModels configuration
Configuration data.
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
TParams_CombineIModels_IModel_Links
TParams_CombineIModels_IModel
Group and map configuration properties
Configuration data.
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Group and map created configuration transformation parameters
Array of EC schemas that will be added to target iModel after transformation.
Link to a mapping
Link to a group
Combine physical models v2 configuration
Indicates if unselected models must be grouped
Name of unselected models group. Must be specified if groupUnselectedModels is set to true.
optional parameter indicating if geometry simplification should be used (transforming parasolids to meshes). Default if not specified - false.
Group unselected models properties
Name for grouped models
Query for grouping models
Combine physical models v2 configuration properties
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Combine physical models v2 configuration transform parameters.
Create fork configuration properties
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Import iModel configuration properties
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Merge iModel configuration properties
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Populate Federation Guids configuration properties
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Merge fork configuration transform parameters links
Merge fork configuration transform parameters
Merge fork configuration properties
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Configurations (prefer return=minimal)
List of Configurations in minimal representation.
Configurations (prefer return=representation)
List of Configurations in full representation.
List of Configurations in full representation.
Minimal configuration
ID of the configuration.
User friendly name of the transformation.
Links
Single iModel Configuration Links
Pagination links
Link
Link to a resource.
EC class definition
EC Schema name
EC Class name
EC schema definition
EC Schema name
EC Schema version
Returned group override properties
ImportIModel configuration properties
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
Was this page helpful?