Table of contents
Transformations
Download API definition:
DELETE https://qa-api.bentley.com/transformations/{transformationId}

This endpoint is used to delete an ongoing transformation for a provided transformationId.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Authorization

You must have imodels_write assigned at the target project level and imodels_read assigned at the source project level within related configuration. If permissions at the project level are not configured, then you must have same assigned at the iModel level.

Alternatively, you must be an Organization Administrator for the Organization that owns a given project the iModel belongs to.

An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management see Bentley Communities Licensing, Cloud, and Web Services wiki page.

Rate limits

All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.

Request parameters

Name
Required?
Description
transformationId
Yes

ID of the transformation

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Response 200 OK

Returns deleted transformation with the given ID.

json
{
    "transformation": {
        "id": "00000000-0000-0000-0000-000000000000",
        "status": "Aborted",
        "errorMessage": "",
        "processedElementCount": 0,
        "totalElementCount": 100,
        "createdDateTime": "2024-03-05T14:51:33.6133333Z",
        "startedDateTime": "2021-08-02T14:51:33.6133333Z",
        "finishedDateTime": "2021-08-02T14:51:33.6133333Z",
        "sourceChangeSetId": "0",
        "lastTargetChangesetPushed": "0",
        "_links": {
            "configuration": {
                "href": "https://api.bentley.com/transformations/configurations/00000000-0000-0000-0000-000000000000"
            }
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 403 Forbidden

User has insufficient permissions.

json
{
    "error": {
        "code": "InsufficientPermissions",
        "message": "The user has insufficient permissions for the requested operation."
    }
}

Response 404 Not Found

Transformation with the given ID does not exist.

json
{
    "error": {
        "code": "TransformationNotFound",
        "message": "Requested Transformation is not available."
    }
}

Response 429 Too many requests

This response indicates that the client sent more requests than allowed by this API for the current tier of the client.

json
{
    "error": {
        "code": "RateLimitExceeded",
        "message": "The client sent more requests than allowed by this API for the current tier of the client."
    }
}

Response headers

Name
Description
retry-after

Number of seconds to wait until client is allowed to make more requests.

Transformation status

Name
Type
Description
Created
String
Started
String
Succeeded
String
Failed
String
Aborted
String
Initializing
String

Transformation

Name
Type
Description
transformation

Transformation

Transformation data.

Name
Type
Description
id
String

ID of the transformation.

status

Available values: Created, Initializing, Started, Succeeded, Failed, Aborted.

errorCode
Int32

Error code that gets filled if an error occurred during transformation.

errorMessage
String, null

Error message that gets filled if an error occurred during transformation.

processedElementCount
Int32

Number of elements that have been processed.

totalElementCount
Int32

Total amount of elements to process.

createdDateTime
Date-time

Time the transformation entity was created.

startedDateTime
Date-time, null

Time the transformation was initiated.

finishedDateTime
Date-time, null

Time the transformation was finished. Empty if transformation is still running.

sourceChangeSetId
String, null

ID of the last change set used for source iModel.

lastTargetChangesetPushed
String, null

ID of last changeset pushed to target iModel.

_links

Link to related configuration.

Links

Name
Type
Description
configuration

Link to configuration.

Link

Name
Type
Description
href
String

Link to a resource.

Error

Contains error information.

Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String, null

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

Name
Type
Description
error

Error information.

Was this page helpful?