Table of contents
Storage
Download API definition:
This operation is a Technical Preview and is available for testing purposes only. Do not use in production.
POST https://qa-api.bentley.com/storage/folders/{folderId}/unlock

Unlock the Files in the Folder.

The folderId MUST be provided in the parameters.

As shown in the request section below, you must provide a fileIds of the files you want to unlock inside the folder with folderId.

Parameters

folderId – Id of the folder in which you want to unlock files.

Note

You can get the fileIds of the files in the folder with folderId using the Get Files in Folder in its response you can see if the file is locked if isFileLocked is set to true.

Please provide the fileIds of the files which are present in the folder with folderId and are locked, if you provide any invalid id or fileIds which are not present in the folder then as shown in the Error it will return 404 NotFound.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Authorization

User must be an Organization Administrator for the Organization that owns a given Project or have storage_write permission assigned at the Project level.

An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.

Request parameters

Name
Required?
Description
folderId
Yes

Id of the folder in which you want to unlock files

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Request body

lock files

Name
Type
Required?
Description
fileIds
String[]
No

Example

json
{
    "fileIds": [
        "TYJsPN0xtkWId0yUrXkS5pN5AQzuullIkxz5aDnDJSI",
        "TYJsPN0xtkWId0yUrXkS5s4FlCroosBMlyDhZZmlzoc"
    ]
}

Response 200 OK

OK

json
{
    "files": [{
        "id": "TYJsPN0xtkWId0yUrXkS5pN5AQzuullIkxz5aDnDJSI",
        "displayName": "test.txt",
        "description": "test file",
        "path": "folderName/test.txt",
        "size": 1,
        "isFileLocked": false,
        "lastModifiedByDisplayName": "Bob User",
        "createdDateTime": "2020-05-03T11:05:11.0133549Z",
        "lastModifiedDateTime": "2020-05-03T11:05:11.0133549Z",
        "parentFolderId": "TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s",
        "_links": {
            "createdBy": {
                "href": "https://api.bentley.com/accesscontrol/itwins/6959daff-27f5-4b87-96ea-9917daa3a8ff/members/1140f95b-1ba0-49d9-bbf4-b53e54d80387"
            },
            "lastModifiedBy": {
                "href": "https://api.bentley.com/accesscontrol/itwins/6959daff-27f5-4b87-96ea-9917daa3a8ff/members/1140f95b-1ba0-49d9-bbf4-b53e54d80387"
            },
            "parentFolder": {
                "href": "https://api.bentley.com/storage/folders/TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s"
            }
        }
    }],
    "_links": {
        "self": {
            "href": "https://api.bentley.com/storage/folders/TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s/files?$skip=4&$top=2"
        },
        "prev": {
            "href": "https://api.bentley.com/storage/folders/TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s/files?$skip=2&$top=2"
        },
        "next": {
            "href": "https://api.bentley.com/storage/folders/TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s/files?$skip=6&$top=2"
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

File or Folder cannot be found.

json
{
    "error": {
        "code": "FileNotFound",
        "message": "Requested fileIds are not available.",
        "details": [{
            "code": "FileNotFound",
            "message": "Requested file TYJsPN0xtkWId0yUrXkS5pN5AQzuullIkxz5aDnDJSI is not available.",
            "target": "fileIds"
        }]
    }
}

Response 409 Conflict

File is/are already locked by another user.

json
{
    "error": {
        "code": "FileInUse",
        "message": "Requested fileIds are already locked by another user.",
        "details": [{
            "code": "FileInUse",
            "message": "Requested file TYJsPN0xtkWId0yUrXkS5pN5AQzuullIkxz5aDnDJSI is locked by another user.",
            "target": "fileIds"
        }]
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

links (paging)

URLs for redoing the current request, getting to the previous or next page of results, if applicable containg.

Name
Type
Description
self

URL for redoing the current request.

next

URL for getting the next page of results.

prev

URL for getting the previous page of results.

link

Hyperlink container.

Name
Type
Description
href
String

Hyperlink to the specific entity.

file-details type

Identification of the file entity.

Name
Type
Description
file
String

file-details

Name
Type
Description
file-details type

Identification of the file entity.

size
Integer

Size to the file in bytes.

isFileLocked
Boolean, null

Indicate whether the file is locked or not.

lock files

Model for locking the files.

Name
Type
Description
fileIds
String[]

files-details-response

List of files.

Name
Type
Description
_links

Contains the hyperlinks to the previous and next pages of results.

Error

Contains error information.

Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String, null

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

Name
Type
Description
error

Error information.