Restore deleted file from the recycle bin
The fileId
MUST be provided in the parameters.
Parameters
fileId
– Id of the file present in recycle bin which you want to restore.
### Notes
file will be restored at the same location from where it was deleted.
If you add or change request body format, you will reset your changes to body content. So, Do not add anything in body.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must be an Organization Administrator for the Organization that owns a given Project or have storage_delete
permission assigned at the Project level.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.