Table of contents
Storage
Download API definition:
POST https://qa-api.bentley.com/storage/files/{fileId}/move

Move the file.

The fileId MUST be provided in the parameters.

As shown in the request section below, you MUST provide a parentFolderId in the request body.

parentFolderId is an id of the folder in which you want to move the file with fileId.

Parameters

fileId – Id of the file which you want to move.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Authorization

User must be an Organization Administrator for the Organization that owns a given Project or have storage_write permission assigned at the Project level.

An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.

Request parameters

Name
Required?
Description
fileId
Yes

Id of the file which you want to move

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Request body

item (move)

Name
Type
Required?
Description
parentFolderId
String
Yes

Folder Id to which the item should be moved.

Example

json
{
    "parentFolderId": "TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s"
}

Response 200 OK

OK

json
{
    "file": {
        "id": "TYJsPN0xtkWId0yUrXkS5pN5AQzuullIkxz5aDnDJSI",
        "displayName": "test.txt",
        "description": "test file",
        "path": "folderName/test.txt",
        "size": 8,
        "lastModifiedByDisplayName": "Bob User",
        "createdDateTime": "2020-05-03T11:05:11.0133549Z",
        "lastModifiedDateTime": "2021-05-15T12:07:06.7841448Z",
        "parentFolderId": "TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s",
        "_links": {
            "createdBy": {
                "href": "https://api.bentley.com/accesscontrol/itwins/6959daff-27f5-4b87-96ea-9917daa3a8ff/members/1140f95b-1ba0-49d9-bbf4-b53e54d80387"
            },
            "lastModifiedBy": {
                "href": "https://api.bentley.com/accesscontrol/itwins/6959daff-27f5-4b87-96ea-9917daa3a8ff/members/1140f95b-1ba0-49d9-bbf4-b53e54d80387"
            },
            "parentFolder": {
                "href": "https://api.bentley.com/storage/folders/TYJsPN0xtkWId0yUrXkS5g0CIYaGZLxEozrWBCOcS_s"
            }
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

File or Folder cannot be found.

json
{
    "error": {
        "code": "FileNotFound",
        "message": "Requested file is not available."
    }
}

Response 409 Conflict

File already exists in folder.

json
{
    "error": {
        "code": "DuplicateInstance",
        "message": "File already exists in folder."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

file (response)

Retrieved file response containing file.

Name
Type
Description
file

Full representation of the file.

file-details type

Identification of the file entity.

Name
Type
Description
file
String

file-details

Name
Type
Description
file-details type

Identification of the file entity.

size
Integer

Size to the file in bytes.

isFileLocked
Boolean, null

Indicate whether the file is locked or not.

item (move)

Model for moving file or folder.

Name
Type
Description
parentFolderId
String

Folder Id to which the item should be moved.

Error

Contains error information.

Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String, null

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

Name
Type
Description
error

Error information.