Get deleted folders and files which are currently present in recycle bin of the provided iTwinId.
The iTwinId
MUST be provided in the parameters.
While the old endpoint remain supported for backward compatibility, we strongly recommend transitioning to the new endpoints to take full advantage of the latest features and improvements.
Old Endpoints: https://dev-api.bentley.com/storage/recyclebin?projectId={PROJECT_ID}
- Parameters:
projectId
- id of the project. - Status: Supported
New Endpoints: https://dev-api.bentley.com/storage/recyclebin?iTwinId={ITWIN_ID}
- Parameters:
iTwinId
- id of the iTwin. - Status: Supported
Parameters
iTwinId
– Id of the iTwin.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must be an Organization Administrator for the Organization that owns a given Project or have storage_read
permission assigned at the Project level.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.