Delete the File with the provided fileId
.
The fileId
MUST be provided in the parameters.
Parameters
fileId
– Id of the file which you want to delete.
Notes
Deleted file will be moved to recycle bin. You can restore the deleted file with in 30 days.
After 30 days, the file will be permanently removed from the Recycle Bin
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must be an Organization Administrator for the Organization that owns a given Project or have storage_delete
permission assigned at the Project level.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.