Create new file in the folder.
As shown in the request section below, you must provide a request body.
The displayName
MUST be provided in the request body, and the folderId
MUST be provided in the parameters.
Parameters
folderId
– Id of the folder in which you want to create the file. File will be created in the folder with provided folderId.
Notes
File creation is a three step process. This request will create file's meta data. Next two requests need to be executed by using links from the response.
uploadUrl is required for file upload. Upload can be done by sending http PUT request and specifying
x-ms-blob-type
header toBlockBlob
. You can use Postman, Azcopy or any libraries with support Azure blob upload to upload the file to provided uploadUrl.completeUrl is used to confirm file upload and it is final request for file creation.
Maximum file size to upload with single request is 256 MiB. If bigger file needs to be uploaded there are ways to use Azure libraries to upload file via given Azure SAS url or by uploading file with multiple requests.
For large size file upload you can upload the file in chunks using FileStream depending on the tech-stack you are using.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must be an Organization Administrator for the Organization that owns a given Project or have storage_write
permission assigned at the Project level.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.
Errors
This request can return InvalidCreateFileRequest error with 422 status code. This could happen because of these reasons:
- File name contains invalid characters.
- File name's length is larger than 255 characters.
- File could be harmful. For example, executable files are not accepted.