Retrieve job progress.
Parameters
The job id
Remarks
The job progression is deemed valid when the job is active and won't be available after 30 days.
Client should query with a backoff intervals [15,30,60,120] seconds. The interval between the first and second query is 15 sec and then 30 sec... If the percentage changes the sequence is restarted.
Authentication
Requires Authorization
header with valid Bearer token for scope realitydataanalysis:read
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Request parameters
Request headers
OAuth access token with scope realitydataanalysis:read
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Response 200 OK
OK
{ "progress": { "percentage": 56, "state": "active", "step": "Run_Production" } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "Unauthorized", "message": "Access denied due to invalid access_token. Make sure to provide a valid token for this API endpoint." } }
Response 404 Not Found
Not Found
{ "error": { "code": "ProgressNotFound", "message": "Requested progress is not available." } }
Response 429 Too many requests
This response indicates that the user has sent too many requests in a given amount of time.
{ "error": { "code": "TooManyRequests", "message": "More requests were received than the subscription rate-limit allows." } }
Response headers
The number of requests exceeds the rate-limit for the client subscription.
Job state
Possible state of a job among 'unsubmitted', 'active', 'success', 'failed' and 'cancelled'.
{ "title": "Job state", "enum": [ "unsubmitted", "active", "success", "failed", "cancelled" ], "description": "Possible state of a job among 'unsubmitted', 'active', 'success', 'failed' and 'cancelled'." }
Progress
Job progress information
{ "title": "Progress", "description": "Job progress information", "type": "object", "properties": { "percentage": { "description": "Job progress percentage.", "type": "number", "format": "double" }, "state": { "$ref": "#/components/schemas/state", "description": "Current job state" }, "step": { "type": "string", "description": "Current job step" } } }
Progress response
{ "title": "Progress response", "type": "object", "properties": { "progress": { "$ref": "#/components/schemas/progress", "description": "Progress details" } }, "required": [ "progress" ] }
error-response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
One of a server-defined set of error codes.
A human-readable representation of the error.
{ "type": "object", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "type": "object", "description": "The error object.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." } } } } }
Error
Contains error information and an optional array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
{ "type": "object", "description": "Contains error information and an optional array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/ErrorDetails" } } }, "required": [ "code", "message" ] }
Error Details
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
{ "type": "object", "title": "Error Details", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." } }, "required": [ "code", "message" ] }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ] }
Was this page helpful?