Create a new job to convert point cloud formats to web-friendly Orbit Point Cloud or Cesium 3D Point Cloud. The POST request body MUST include type, name, inputs and outputs. Accepted input formats for conversion are LAS, LAZ, PLY, E57, OPC, PointCloud and ouput formats are OPC, PNTS, GLB and GLBC.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Request body
Job (Create)
Job name.
ITwin Id.
Parameters to be used to estimate the cost of the job.
Example
{ "type": "Conversion", "name": "My first RCS job", "iTwinId": "510cd1a3-3703-4729-b08c-fecd9c87c3be", "costEstimationParameters": { "gigaPixels": 2.5, "megaPoints": 1.5 }, "inputs": [{ "id": "58e0c0ca-f730-4e5b-808d-1c8cacacb4d4" }], "outputs": [ "OPC" ], "options": { "processingEngines": 5, "merge": false } }
Response 201 Created
Created
{ "job": { "id": "cc3d35cc-416a-4262-9714-b359da70b419", "name": "My first RCS job", "type": "Conversion", "state": "unsubmitted", "createdDateTime": "2021-11-04T14:13:27Z", "lastModifiedDateTime": "2020-09-14T14:29:55Z", "iTwinId": "510cd1a3-3703-4729-b08c-fecd9c87c3be", "email": "example@email.com", "dataCenter": "East US", "inputs": [{ "id": "58e0c0ca-f730-4e5b-808d-1c8cacacb4d4", "type": "LAS" }], "outputs": [{ "type": "OPC" }], "options": { "processingEngines": 5, "merge": false }, "costEstimation": { "estimatedCost": 3.5, "gigaPixels": 2.1, "megaPoints": 1.5 } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
This response indicates that user does not have required permissions to create a job.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).
{ "error": { "code": "InvalidRealityConversionRequest", "message": "Cannot create job.", "details": [{ "code": "InvalidProperty", "message": "The Name field is required.", "target": "Name" }] } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Job (Create)
Model for creating a new job.
Job name.
ITwin Id.
Parameters to be used to estimate the cost of the job.
{ "title": "Job (Create)", "description": "Model for creating a new job.", "type": "object", "properties": { "type": { "$ref": "#/components/schemas/jobType", "description": "Job type." }, "name": { "type": "string", "description": "Job name." }, "iTwinId": { "type": "string", "description": "ITwin Id." }, "costEstimationParameters": { "$ref": "#/components/schemas/costEstimationParameters", "description": "Parameters to be used to estimate the cost of the job." }, "options": { "$ref": "#/components/schemas/jobOptions", "description": "List of optional parameters to create job." }, "inputs": { "type": "array", "items": { "$ref": "#/components/schemas/jobCreateInput" }, "description": "List of inputs of the job." }, "outputs": { "type": "array", "items": { "$ref": "#/components/schemas/jobCreateOutput" }, "description": "List of output formats of the job." } }, "required": [ "type", "name", "inputs", "outputs", "iTwinId" ], "additionalProperties": false }
Job Input
Input description for a job.
Id of the input.
{ "type": "object", "title": "Job Input", "description": "Input description for a job.", "properties": { "id": { "type": "string", "description": "Id of the input." } }, "additionalProperties": false }
Job Output
List of available output formats.
- OPC: Orbit Point Cloud
- PNTS: OGC 3DTiles Point Cloud 1.0
- GLB: OGC 3DTiles Point Cloud 1.1
- GLBC: OGC 3DTiles Point Cloud 1.1 Compressed.
{ "title": "Job Output", "enum": [ "OPC", "PNTS", "GLB", "GLBC" ], "description": "List of available output formats.\n- OPC: Orbit Point Cloud\n- PNTS: OGC 3DTiles Point Cloud 1.0\n- GLB: OGC 3DTiles Point Cloud 1.1\n- GLBC: OGC 3DTiles Point Cloud 1.1 Compressed." }
Job
Full representation of a job.
Job unique id.
Job name.
iTwin Id.
owner Id.
Creation time of the job.
Last modification date of the job.
Datacenter location of the job.
User email address.
{ "title": "Job", "description": "Full representation of a job.", "type": "object", "properties": { "id": { "type": "string", "description": "Job unique id." }, "name": { "type": "string", "description": "Job name." }, "type": { "$ref": "#/components/schemas/jobType", "description": "Job type." }, "state": { "$ref": "#/components/schemas/jobState", "description": "Job current state." }, "iTwinId": { "type": "string", "description": "iTwin Id." }, "ownerId": { "type": "string", "description": "owner Id." }, "createdDateTime": { "type": "string", "format": "date-time", "description": "Creation time of the job." }, "lastModifiedDateTime": { "type": "string", "format": "date-time", "description": "Last modification date of the job." }, "dataCenter": { "type": "string", "description": "Datacenter location of the job." }, "email": { "type": "string", "description": "User email address." }, "executionInformation": { "$ref": "#/components/schemas/executionInformation", "description": "Execution information of the job." }, "costEstimation": { "$ref": "#/components/schemas/costEstimation", "description": "Parameters to be used to estimate the cost of the job." }, "inputs": { "description": "List of inputs of the job.", "items": { "$ref": "#/components/schemas/jobInput" }, "type": "array" }, "outputs": { "description": "List of outputs of a job.", "items": { "$ref": "#/components/schemas/jobOutput" }, "type": "array" }, "options": { "$ref": "#/components/schemas/jobOptions", "description": "List of optional parameters to create job." } }, "required": [ "id", "name", "type", "state", "createdDateTime", "lastModifiedDateTime", "dataCenter", "inputs", "outputs", "iTwinId" ], "additionalProperties": false }
Job Response
{ "title": "Job Response", "type": "object", "properties": { "job": { "$ref": "#/components/schemas/job", "description": "Complete job details." } }, "required": [ "job" ], "additionalProperties": false }
Job Type
Job type.
{ "title": "Job Type", "type": "string", "enum": [ "Conversion" ], "description": "Job type." }
Job State
Job state.
{ "title": "Job State", "type": "string", "enum": [ "unsubmitted", "active", "success", "failed", "cancelled" ], "description": "Job state." }
Job Input Formats
List of available input formats.
{ "title": "Job Input Formats", "description": "List of available input formats.", "enum": [ "LAS", "LAZ", "PLY", "E57", "OPC", "PointCloud" ] }
Job Input
Input description for a job.
Id of the input.
{ "type": "object", "title": "Job Input", "description": "Input description for a job.", "properties": { "type": { "$ref": "#/components/schemas/jobInputFormats", "description": "Input type for a job." }, "id": { "type": "string", "description": "Id of the input." } }, "additionalProperties": false }
Job Output Formats
List of available output formats.
{ "title": "Job Output Formats", "description": "List of available output formats.", "enum": [ "OPC", "PNTS", "GLB", "GLBC" ] }
Job Output
Output description for a job.
Id of the input.
{ "type": "object", "title": "Job Output", "description": "Output description for a job.", "properties": { "type": { "$ref": "#/components/schemas/jobOutputFormats", "description": "Output format for a job." }, "id": { "type": "string", "description": "Id of the input.", "nullable": true } }, "additionalProperties": false }
Options
List of optional parameters to create job.
Number of engines to be used at most, between 0 and your engine limit. If set at 0, RCS will use your engine limit.
If true, then all the input files from multiple containers will be merged into one output file. Else output file will be created per input file.
{ "type": "object", "title": "Options", "description": "List of optional parameters to create job.", "properties": { "processingEngines": { "type": "integer", "description": "Number of engines to be used at most, between 0 and your engine limit. If set at 0, RCS will use your engine limit." }, "merge": { "type": "boolean", "description": "If true, then all the input files from multiple containers will be merged into one output file. Else output file will be created per input file." } }, "additionalProperties": false }
Execution Info
Execution information of the job.
Submission time of the job.
Start time of the job.
End time of the job.
Estimated processing units cost.
{ "title": "Execution Info", "description": "Execution information of the job.", "type": "object", "properties": { "submissionDateTime": { "type": "string", "format": "date-time", "description": "Submission time of the job." }, "startedDateTime": { "type": "string", "format": "date-time", "description": "Start time of the job.", "nullable": true }, "endedDateTime": { "type": "string", "format": "date-time", "description": "End time of the job.", "nullable": true }, "estimatedUnits": { "type": "number", "description": "Estimated processing units cost.", "nullable": true } }, "required": [ "submissionDateTime" ], "additionalProperties": false }
Cost Estimation Parameters
Parameters to be used to estimate the cost of the job.
Gigapixels to be processed.
Megapoints to be processed.
{ "title": "Cost Estimation Parameters", "description": "Parameters to be used to estimate the cost of the job.", "type": "object", "properties": { "gigaPixels": { "type": "number", "description": "Gigapixels to be processed." }, "megaPoints": { "type": "number", "description": "Megapoints to be processed." } }, "additionalProperties": false }
Cost Estimation Information
Cost estimate based on parameters before job processing.
Number of giga pixels in inputs.
Number of mega points in inputs.
Estimated cost of the job using the CostEstimationParameters.
{ "type": "object", "title": "Cost Estimation Information", "description": "Cost estimate based on parameters before job processing.", "properties": { "gigaPixels": { "description": "Number of giga pixels in inputs.", "type": "number", "format": "double", "nullable": true }, "megaPoints": { "description": "Number of mega points in inputs.", "type": "number", "format": "double", "nullable": true }, "estimatedCost": { "type": "number", "description": "Estimated cost of the job using the CostEstimationParameters.", "format": "double" } }, "additionalProperties": false }
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information and an array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/Error" } } }, "required": [ "code", "message", "details" ], "additionalProperties": true }
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Detailed Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error Detailed information.", "$ref": "#/components/schemas/DetailedError" } }, "required": [ "error" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?