Returns all PnID Inference Inputs.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Request parameters
Id of the created PnID Inference.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v2+json
is required.
Response 200 OK
List of PnID Inference Inputs returned successfully.
{ "inputs": [{ "id": "cG5pZC5wZGY-", "filename": "pnid.pdf", "size": 100, "_links": { "input": { "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3/inputs/cG5pZC5wZGY-" }, "content": { "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3/inputs/cG5pZC5wZGY-/content" } } }], "_links": { "self": { "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3/inputs" }, "inference": { "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3" } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 404 Not Found
Specified Inference was not found.
{ "error": { "code": "PnIDInferenceRunNotFound", "message": "Requested PnID Inference Run is not available." } }
Response 429 Too many requests
This response indicates that the user has sent too many requests in a given amount of time.
{ "error": { "code": "TooManyRequests", "message": "More requests were received than the subscription rate-limit allows." } }
Response headers
The number of requests exceeds the rate-limit for the client subscription.
Link
Hyperlink container.
Hyperlink to the specific entity.
PnID Inference Input Links
Contains the hyperlinks to related data of PnID Inference Inputs.
PnID Inference Input
Represents input file for PnID Inference.
File Id of PnID Inference Input
Filename of PnID Inference Input.
File size of PnID Inference Input.
Paging Links with inference link
URL for getting inference.
PnID Inference Input Page
List of PnID Inference Inputs.
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.