Creates new PnID Inference for a specific model version. This endpoint registers a new inference pipeline in Azure Machine Learning service with already trained PnID (Piping & Instrumentation Diagrams) ML model. To create new PnID Inference please provide iTwin ID and model version. All available model versions are listed in the Model versions section.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v2+json
is required.
Request body
PnID Inference Payload
ML Model version for PnID Inference.
Id of the iTwin that created the PnID Inference.
Example
{ "modelVersion": "1.3", "iTwinId": "ea9cb5ab-22c5-4cef-807a-df47f07b01f3" }
Response 201 Created
Inference created successfully.
{ "inference": { "id": "bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3", "modelVersion": "1.3", "lastModifiedDateTime": "2022-01-20T14:45:47.073Z", "createdDateTime": "2022-01-20T14:45:47.073Z", "_links": { "iTwin": { "href": "https://api.bentley.com/itwins/ea9cb5ab-22c5-4cef-807a-df47f07b01f3" }, "run": { "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3/run" }, "inputs": { "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3/inputs" }, "results": { "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3/run/results" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
The user has insufficient permissions for the requested operation.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax)
{ "error": { "code": "InvalidPnIDtoiTwinRequest", "message": "Cannot create requested resource.", "details": [{ "code": "MissingRequiredProperty", "message": "Required property is missing.", "target": "modelVersion" }] } }
Response 429 Too many requests
This response indicates that the user has sent too many requests in a given amount of time.
{ "error": { "code": "TooManyRequests", "message": "More requests were received than the subscription rate-limit allows." } }
Response headers
The number of requests exceeds the rate-limit for the client subscription.
Link
Hyperlink container.
Hyperlink to the specific entity.
PnID Inference
PnID Inference details.
Unique PnID Inference identifier.
ML Model version for PnID Inference.
Date time of last PnID Inference modification.
Date time of PnID Inference creation.
PnID Inference Payload
Properties of PnID Inference to be created.
ML Model version for PnID Inference.
Id of the iTwin that created the PnID Inference.
PnID Inference Result
Container for PnID Inference.
PnIDInferenceLinks
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.