Patch a job to modify it (type, settings, cost estimation parameters), submit or cancel it.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Request parameters
Job Id
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Request body
jobPatch (State)
Parameters to be used to estimate the cost of the job
Example
{ "state": "Active" }
jobPatch (Settings)
Parameters to be used to estimate the cost of the job
Example
{ "settings": { "quality": "Extra", "processingEngines": 5, "outputs": [ "OBJ", "3MX" ] } }
jobPatch (CostEstimationParameters)
Parameters to be used to estimate the cost of the job
Example
{ "costEstimationParameters": { "gigaPixels": 2.5, "megaPoints": 1.7, "meshQuality": "Extra" } }
Response 200 OK
Job was successfully updated.
{ "job": { "id": "cc3d35cc-416a-4262-9714-b359da70b419", "name": "My first Reality Modeling job", "type": "Full", "state": "active", "createdDateTime": "2020-09-14T14:29:55Z", "lastModifiedDateTime": "2020-09-14T14:29:55Z", "iTwinId": "3fa85f64-5717-4562-b3fc-2c963f66afa6", "location": "East US", "email": "john.smith@example.com", "workspaceId": "6881117d-9fd2-4900-870b-9b721dc90f25", "executionInformation": { "submittedDateTime": "2020-09-14T14:35:06Z" }, "inputs": [{ "id": "58e0c0ca-f730-4e5b-808d-1c8cacacb4d4", "description": "Drone ImageCollection" }, { "id": "dc65ce7d-2598-422f-97a5-5ae8eb004b67", "description": "Drone CCOrientations" } ], "jobSettings": { "quality": "Extra", "outputs": [{ "format": "OBJ", "id": "3ddee08c-01e8-44a5-8e56-3879109f6728" }, { "format": "3MX", "id": "f18fc6c3-2224-4d63-a04b-52bd18805d01" } ], "processingEngines": 5, "cacheSettings": { "createCache": true, "useCache": "799b11bd-71cf-481a-b284-bf48f672cd9a" } }, "costEstimationParameters": { "gigaPixels": 2.1, "megaPoints": 1.5, "meshQuality": "Extra" }, "estimatedCost": 3.5 } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 404 Not Found
Not Found
{ "error": { "code": "JobNotFound", "message": "Requested job is not available." } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).
{ "error": { "code": "InvalidContextCaptureRequest", "message": "Cannot modify job.", "details": [{ "code": "InvalidChange", "message": "Cannot resubmit an already submitted job." }] } }
Response 429 Too many requests
This response indicates that the user has sent too many requests in a given amount of time.
{ "error": { "code": "TooManyRequests", "message": "More requests were received than the subscription rate-limit allows." } }
Response headers
The number of requests exceeds the rate-limit for the client subscription.
Output format
Output format among 'CCOrientations', '3MX', '3SM', 'WebReady ScalableMesh', 'Cesium 3D Tiles', 'POD', 'Orthophoto/DSM', 'LAS', 'FBX', 'OBJ', 'ESRI i3s', 'DGN', 'LODTreeExport', 'PLY', 'OPC', OMR and ContextScene.
Job quality
Job quality among 'Draft', 'Medium' and 'Extra'
Cost Estimation Parameters
Parameters to be used to estimate the cost of the job
Gigapixels to be processed
Megapoints to be processed
Job Input
Description of an input for a job
Context Share reality data id of the input
Description of the input
Cache settings
Describe how a job will use and create cache
Indicate if the job will produce a cache
Id of the previous job cache to be reused
Job Patch Settings
Settings for job patch
Maximum usable engines for the job
Error and Warning messages
Model for error and warning messages
Error or warning message code
Error or warning message title
Error or warning message
Error or warning message parameters
Execution Info
Execution information relative to a job
Submission time of the job
Start time of the job
End time of the job
Estimated processing units cost
Job Output
Job output information
Reality Data Id of the output
Job Settings
High-level job settings
Maximum usable engines for the job
Job type
Job type among 'Full', 'Calibration' and 'Reconstruction'
Job state
Job current state
Job location
Datacenter location of the job
Job
Job information
Job unique id
Job name
Creation time of the job
Last modification date of the job
Project Id
Workspace id relative to the job
User email address
Parameters to be used to estimate the cost of the job
Estimated Cost of the job using the CostEstimationParameters
Job response
Job Patch state
Job state to be patched to
Job Patch type
Job type among 'Full', 'Calibration' and 'Reconstruction'
Job Patch
Patch object to patch, submit, cancel a job
Parameters to be used to estimate the cost of the job
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.