Obtains which elements have changed in the iModel between the given start and end changesets.
This information will only be available after change tracking has been enabled and the processing operation completes.
Understanding Change
The comparison returns a ChangedElements object. This interface contains different arrays of the same size. Each element is specified by a single index in all arrays. Some of the relevant arrays to understand what changes occurred to an element are listed below:
opcodes: Contains the operation codes that tells us if the element was inserted, updated, or deleted in the change. See DbOpcode for more information. The appropriate values are listed below:
 Â
type: Contains the type of change that occurred to the element. This number is a bit-flag and can be used to know whether the element had property changes, geometric changes, placement changes, indirect changes, and hidden property changes. See TypeOfChange for more information. Below is a table with the values and their meaning:
Authentication
Requires Authorization
header with valid Bearer token for scope changedelements:read
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.